Remove lint errors in non-java files. Fix download dialog when download size is...
[PrivacyBrowser.git] / app / src / main / res / drawable / create_folder.xml
index 0ac318e16de0b37bcb64fcdc3fcb1b4b886c396c..77bed7acde25e0e7cdaa757d7d322d693f01a6f2 100644 (file)
@@ -1,14 +1,18 @@
 <!-- create_folder.xml comes from the Android Material icon set, where it is called ic_create_new_folder.
 <!-- create_folder.xml comes from the Android Material icon set, where it is called ic_create_new_folder.
-  It is released under the CC-BY license <https://creativecommons.org/licenses/by/4.0/>. -->
+    It is released under the Apache License 2.0. -->
 
 
+<!-- `tools:ignore="VectorRaster"` removes the lint warning about `android:autoMirrored="true" not applying to API < 21. -->
 <vector
     xmlns:android="http://schemas.android.com/apk/res/android"
 <vector
     xmlns:android="http://schemas.android.com/apk/res/android"
+    xmlns:tools="http://schemas.android.com/tools"
     android:height="24dp"
     android:width="24dp"
     android:viewportHeight="24.0"
     android:viewportWidth="24.0"
     android:height="24dp"
     android:width="24dp"
     android:viewportHeight="24.0"
     android:viewportWidth="24.0"
-    android:autoMirrored="true" >
+    android:autoMirrored="true"
+    tools:ignore="VectorRaster" >
 
 
+    <!-- We have to use a hard coded color code until API >= 21.  Then we can use `@color`. -->
     <path
         android:fillColor="#FFFFFFFF"
         android:pathData="M20,6h-8l-2,-2L4,4c-1.11,0 -1.99,0.89 -1.99,2L2,18c0,1.11 0.89,2 2,2h16c1.11,0 2,-0.89 2,-2L22,8c0,-1.11 -0.89,-2 -2,-2zM19,14h-3v3h-2v-3h-3v-2h3L14,9h2v3h3v2z"/>
     <path
         android:fillColor="#FFFFFFFF"
         android:pathData="M20,6h-8l-2,-2L4,4c-1.11,0 -1.99,0.89 -1.99,2L2,18c0,1.11 0.89,2 2,2h16c1.11,0 2,-0.89 2,-2L22,8c0,-1.11 -0.89,-2 -2,-2zM19,14h-3v3h-2v-3h-3v-2h3L14,9h2v3h3v2z"/>