Change asset image links to use relative paths so the project will build on F-Droid.
[PrivacyBrowser.git] / app / build.gradle
index c215b003a2c7a174dca69a0ba8d334a441eab7ce..22cfd8f3aa4df0e1edbf7b77c6d46484a24705a4 100644 (file)
@@ -24,18 +24,18 @@ android {
     }
 
     compileSdkVersion 23
-    buildToolsVersion "23.0.2"
+    buildToolsVersion "23.0.3"
     defaultConfig {
         applicationId "com.stoutner.privacybrowser"
-        minSdkVersion 10
+        minSdkVersion 19
         targetSdkVersion 23
-        versionCode 2
-        versionName "1.1"
+        versionCode 10
+        versionName "1.9"
     }
 
     buildTypes {
         release {
-            minifyEnabled false
+            minifyEnabled true
             proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
         }
     }
@@ -43,21 +43,17 @@ android {
     productFlavors {
         standard {
             applicationId "com.stoutner.privacybrowser.standard"
-            versionName "1.1-standard"
         }
 
         free {
             applicationId "com.stoutner.privacybrowser.free"
-            versionName "1.1-free"
         }
     }
 }
 
 dependencies {
     compile fileTree(dir: 'libs', include: ['*.jar'])
-    compile 'com.android.support:appcompat-v7:23.2.0'
-    compile 'com.android.support:design:23.2.0'
-    compile 'com.android.support:support-v4:23.2.0'
-    // Only compile com.google.android.gms:play-services-ads for the free version so that the standard version can build of F-Droid.
-    freeCompile 'com.google.android.gms:play-services-ads:8.4.0'
+    compile 'com.android.support:design:23.4.0'
+    // Only compile `com.google.android.gms:play-services-ads` for the free flavor.
+    freeCompile 'com.google.android.gms:play-services-ads:9.4.0'
 }